RE: Running cflowd and cflowdmux

From: Stephen R. Gill (gillsr99@yahoo.com)
Date: Tue Mar 13 2001 - 19:45:13 PST

  • Next message: Scott V: "Re: Running cflowd and cflowdmux"

    This is because they are probably failing with an error message. Check
    "cflowd.conf" and verify where they are sending their logs and to what
    facility. From there, set up syslog to properly collect the messages from
    cflowd and cflowdmux. Finally, run a "tail -f <filename>" while you attempt
    to start them up. You have likely forgotten to reconfigure /etc/system on
    solaris to add
    "set shmsys:shminfo_shmmax = 4194304". The default shared buffer size on
    Solaris is not large enough
    to handle what cflowd's requirements are.

    At least, that was my problem. I'm still stuck at compiling cflowd on
    Solaris 2.7 with an error message of:

    ... snip snip ...
    make[1]: Entering directory
    `/export/home/sgill/cflowd-2-1-b1/apps/cflowdmux'
    c++ -g -O2 -c
    CflowdRawFlowClientList.cc -I../../classes/include -I../../include -I. -I/us
    r/local/arts/include
    c++ -g -O2 -c
    cflowdmux.cc -I/usr/local/arts/include -I../../classes/include -I../../inclu
    de -I. -I../../snmp++/classes/include
    mkdir .libs
    c++ -g -O2 CflowdRawFlowClientList.o cflowdmux.o
    ../../classes/lib/.libs/libCfd.a -L/usr/local/arts/lib -lArts
    ../../snmp++/classes/lib/.libs/libsnmp++.a -lfl -lsocket -lnsl -o
    cflowdmux -Wl,--rpath -Wl,/usr/local/arts/lib -Wl,--rpath -Wl,/usr/local/art
    s/lib
    ../../snmp++/classes/lib/.libs/libsnmp++.a: could not read symbols: Archive
    has no index; run ranlib to add one
    collect2: ld returned 1 exit status
    make[1]: *** [cflowdmux] Error 1
    make[1]: Leaving directory `/export/home/sgill/cflowd-2-1-b1/apps/cflowdmux'
    make: *** [cflowdmux] Error 2
    *** Error code 2
    make: Fatal error: Command failed for target `all'
    ... snip snip ...

    Good luck!
    -- steve

    -----Original Message-----
    From: cflowd-owner@ipn.caida.org [mailto:cflowd-owner@ipn.caida.org]On
    Behalf Of Rich Norderhaug
    Sent: Tuesday, March 13, 2001 8:52 PM
    To: cflowd@caida.org
    Subject: Running cflowd and cflowdmux

    I've seen others ask this question, but have still not
    located an answer in the mail archive.

    I'm trying to run cflowd and cflowdmux on a Solaris
    2.6 platform.

    When I attempt to run either cflowd or cflowdmux, I do
    not see them with "ps -ef" and can not locate an error
    message.

    When I attempt to simply run cfdcollect, I see it
    easily with a "ps -ef" command.

    Is there a solution to this problem?

    Thanks,
    Rich

    __________________________________________________
    Do You Yahoo!?
    Yahoo! Auctions - Buy the things you want at great prices.
    http://auctions.yahoo.com/

    --
    cflowd mailing list
    cflowd@caida.org
    

    _________________________________________________________ Do You Yahoo!? Get your free @yahoo.com address at http://mail.yahoo.com

    -- cflowd mailing list cflowd@caida.org



    This archive was generated by hypermail 2b29 : Tue Mar 13 2001 - 19:50:20 PST