RE: My Cisco 7200 dowsn't export any data!

From: Fernando Mayo \(acens\) (fernando.mayo@acens.net)
Date: Fri Aug 17 2001 - 02:40:57 PDT

  • Next message: Nicole Markee: "problems with the tar ball"

    Hi;

    You?re right; I have enabled cef on the router, and inmediately it started
    to send data to cflowd.

    The bug -ID is CSCdv06352

    Thank?s a lot!

    Regards

    > -----Mensaje original-----
    > De: Roman Popov [mailto:rvp@demos.su]
    > Enviado el: jueves, 16 de agosto de 2001 21:02
    > Para: Fernando Mayo (acens)
    > CC: cflowd@caida.org
    > Asunto: Re: My Cisco 7200 dowsn't export any data!
    >
    >
    > This is a cisco ios bug, netflow doesn't work without cef
    > enabled on ioses
    > above 12.1.3T.
    >
    > On Thu, Aug 16, 2001 at 12:02:40PM +0200, Fernando Mayo (acens) wrote:
    > > Hi;
    > >
    > > I have searched into the mail archive, but I didn't find any
    > answer about
    > > this question.
    > >
    > > I'm having some trouble about exporting flow data from a 7200 running
    > > 12.1(5)T4 IOS to my cflowd server (running on Red Hat Linux
    > 6.2, but it is
    > > not relevant, I think).
    > >
    > > Flow export is enabled on the desired interface:
    > >
    > > interface FastEthernet1/0
    > > description Backbone
    > > ip address xxxxxxxxxxxxxxxxxx
    > > no ip unreachables
    > > no ip proxy-arp
    > > ip route-cache same-interface
    > > IP ROUTE-CACHE FLOW
    > > load-interval 30
    > > duplex full
    > > no cdp enable
    > > standby priority 110 preempt
    > > standby ip xxxxxxxxxxxxx
    > >
    > > And flow export is enabled, to a directly attached host, wich is running
    > > cflowd:
    > >
    > > ip flow-export source Loopback0
    > > ip flow-export destination 10.6.1.41 2055
    > >
    > > Here is the output of "debug ip flow export" command:
    > >
    > > router1#debug ip flow export
    > > IP Flow export mechanism debugging is on
    > > 9w1d: IPFLOW: Sending export pak to 10.6.1.41 port 2055
    > > 9w1d: IPFLOW: Sending export pak to 10.6.1.41 port 2055
    > >
    > > So, I should think the router is sending data to cflowd..but it doesn't!
    > > I don't see any traffic coming the router on 2055 port if I run
    > tcpdump on
    > > the cflowd host's interface directly attached to the router,
    > but there is
    > > communication between them, because I can see ICMP packets on
    > that tcpdump
    > > if I ping the cflowd server from the router.
    > >
    > > Here is the output of "show ip flow export" in the router:
    > >
    > > router1#sh ip flow export
    > > Flow export is enabled
    > > Exporting flows to 10.6.1.41 (2055)
    > > Exporting using source interface Loopback0
    > > Version 1 flow records
    > > 1163596 flows exported in 56297 udp datagrams
    > > 0 flows failed due to lack of export packet
    > > 56295 export packets were sent up to process level
    > > 0 export packets were dropped due to no fib
    > > 0 export packets were dropped due to adjacency issues
    > > 0 export packets were dropped due to fragmentation failures
    > > 0 export packets were dropped due to encapsulation fixup failures
    > >
    > > Do you know what is happen ?
    > > Do you know what mean "56295 export packets were sent up to
    > process level"?
    > >
    > > Thanks a lot
    > >
    > > Regards
    > >
    > > Fernando Mayo Tel. Directo: 911418544
    > > http://www.acens.com
    > > fernando.mayo@acens.com
    > >
    > > C/ San Rafael, 14
    > > Pol?gono industrial Alcobendas
    > > 28108 Alcobendas (Madrid)
    > >
    > >
    > >
    > >
    > > --
    > > cflowd mailing list
    > > cflowd@caida.org
    >
    > --
    >
    > wbw
    > Roman Popov
    >

    --
    cflowd mailing list
    cflowd@caida.org
    



    This archive was generated by hypermail 2b29 : Fri Aug 17 2001 - 02:57:35 PDT