Skip to Content
[CAIDA - Center for Applied Internet Data Analysis logo]
Center for Applied Internet Data Analysis
rb-mperio - mper Client Programming Library
rb-mperio is a RubyGem for writing network measurement scripts in Ruby that use the mper probing engine.

Download rb-mperio

rb-mperio is licensed under GPLv2. The latest version of rb-mperio, v0.3.3, was released on Jun 12, 2013 (read the CHANGES).

Download rb-mperio

Installation

Supported Ruby versions are 1.8.6, 1.8.7, and 1.9.x. For Ubuntu and Debian Linux, be sure to also install the Ruby development packages to get Ruby headers necessary to build Ruby C extensions.

If you install Ruby 1.8.6 or 1.8.7, also install RubyGems (a Ruby package manager) after installing Ruby. Check whether you have RubyGems by executing 'gem list' in a shell window (which should run without error if you do).

If you need to install RubyGems (the package manager) manually, download the latest version (rubygems-x.x.x.tgz) from http://rubyforge.org/frs/?group_id=126 and install it with:

        $ tar xvzf rubygems-x.x.x.tgz 
	$ cd rubygems-x-x-x
        $ sudo ruby setup.rb

Now install rb-mperio with

        $ sudo gem install rb-mperio-x.x.x.gem
Confirm installation with 'gem list' (no sudo required), which should show rb-mperio.

Dependencies

You must install and run the mper probing engine in order to execute measurements with rb-mperio.

Authors

rb-mperio is written and maintained by Young Hyun as a part of CAIDA's work on the Archipelago Measurement Infrastructure.

rb-mperio uses some source from scamper, written and maintained by Matthew Luckie, member of the WAND group in the Computer Science Department at the University of Waikato.

Thanks to Alistair King for adding support for IP options and other recent features of mper v0.4.0 and for implementing the mper-trace sample script in Jun-Sep 2011.

  Last Modified: Thu Sep-12-2013 13:22:28 PDT
  Page URL: http://www.caida.org/tools/measurement/rb-mperio/index.xml